Menu Close

New fastloc.FOCI versions to download

I updated all versions of fastloc.FOCI GUI application. Due to major changes implemented in the software, it is recommended to update your version of foci immediately. To update the software, proceed to the dedicated webpage, download and install the version of your choice. The new version fixes the critical error in the automatic update module of the previous versions – the feature was not working appropriately due to the wrong ftp paths, thus the program was unable to update automatically. Besides, the new version fixes minor language problems.